Error: Failed to build source-highlight: command execution failed

Bill Cole macportsusers-20171215 at
Thu May 6 01:53:20 UTC 2021

On 2021-05-05 at 19:39:33 UTC-0400 (Wed, 5 May 2021 19:39:33 -0400)
tom eee <eeetom87 at>
is rumored to have said:

> /Developer is gone and Xcode 4.6.3 in service.  Still failing build.  
> See
> attachment.  Thanks, Tom

That log shows that you are back at the original problem, whose proposed 
solution was to force the use of a newer version of the clang compiler 
by running these:

    sudo port clean source-highlight
    sudo port -s install source-highlight 

However, I've lost track of whether we've actually solved the problem 
you hit the last time you tried that: a broken installation of 
clang-9.0. To make sure that problem is fixed, run this:

    /opt/local/bin/clang-mp-9.0 --version

That should put out something like this:

    clang version 9.0.1
    Target: i386-apple-darwin11.4.2
    Thread model: posix
    InstalledDir: /opt/local/libexec/llvm-9.0/bin

> On Wed, May 5, 2021 at 5:14 PM Ryan Schmidt <ryandesign at> 
> wrote:
>> On May 5, 2021, at 12:19, tom eee wrote:
>>> Second, I retried 'sudo port install source-light' with no success.  
>>> The
>> main.log was very big, so I cut out a big portion of the middle and
>> attached it to this email.
>> The log still shows the same error described in
>> and shows that MacPorts still
>> recognizes that you have Xcode 4.2.
>> Deleting parts of logs can make it harder for us to help you. A 
>> better
>> file size reduction choice is to compress the log.
>>> Third, I downloaded Xcode 4.6.3 and when the opened dmg directed me 
>>> to
>> install the Xcode in my Application folder, I checked for what was 
>> already
>> there first, only to discover that I had Xcode 4.6.3 installed in the
>> Application folder since 2013!  I then looked in the Developer folder 
>> and
>> discovered Xcode 4.2 was there.  So I am confused about how to make 
>> Xcode
>> 4.6.3 the version that MacPorts sees when it is doing it's thing and 
>> do I
>> now have to do some update for Developer?
>> The /Developer folder is obsolete. You can delete it. It is where 
>> Apple
>> used to install Xcode and associated files, but sometime after Xcode 
>> 4.2
>> they stopped doing that. Xcode now belongs in /Applications.
>> You can use "xcode-select -print-path" to see what Xcode your system 
>> is
>> configured to use. MacPorts will use this Xcode.
>> Assuming it does not say the path is
>> /Applications/, change it to that by 
>> running
>> "sudo xcode-select -switch 
>> /Applications/"
>> Then you can run "sudo port clean source-highlight" and try to 
>> install it
>> again.

Bill Cole
bill at or billcole at
(AKA @grumpybozo and many * addresses)
Not Currently Available For Hire

More information about the macports-users mailing list