Re: Is it possible to install Julia on M1 Mac?

petr.2006 at petr.2006 at
Fri May 7 13:01:31 UTC 2021

With gcc10 installation fails as well:

:info:build ===============================================================================
:info:build   ERROR: sha512 checksum failure on LibGit2.v1.2.3+0.aarch64-apple-darwin.tar.gz, should be:
:info:build       cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce
:info:build       47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e
:info:build   But `shasum -a 512 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_julia/julia/work/julia-1.6.1/deps/srccache/LibGit2.v1.2.3+0.aarch64-apple-darwin.tar.gz | awk '{ print $1; }'` results in:
:info:build       aff23e9d56827be54d8f515489eed92d9cb4d9a1b69c12bbee44fa1343ebc906
:info:build       b38b082c11e6ecb227d256de5cba19b2f3a03c022b88809a33c225c34db08f7c
:info:build   This can happen due to bad downloads or network proxies, please check your
:info:build   network proxy/firewall settings and delete
:info:build   /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_julia/julia/work/julia-1.6.1/deps/srccache/LibGit2.v1.2.3+0.aarch64-apple-darwin.tar.gz
:info:build   to force a redownload when you are ready
:info:build ===============================================================================
:info:build make[1]: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_julia/julia/work/julia-1.6.1/usr/manifest/libgit2] Error 2
:info:build make[1]: *** Waiting for unfinished jobs....

I tried to delete the corrupted file but the second install attempt was with the same result.


> Od: "Chris Jones" <jonesc at>
> Komu: "Andrew Rohl" <andrew at>
> Datum: 07.05.2021 14:22
> Předmět: Re: Is it possible to install Julia on M1 Mac?
> CC: <macports-users at>
>Whilst the statement that the devel version of gcc was correct at the time it was made, gcc10 now has had support back ported. So I suggest you force uninstall libgcc-devel and let libgcc10 get installed in its place.
>> On 7 May 2021, at 12:37 pm, Andrew Rohl <andrew at> wrote:
>> I have installed gcc-devel as I was told that it is the only version that can be compiled on the M1.
>> Then tried to install Julia:
>>> sudo port install julia                                                                    
>>> --->  Computing dependencies for julia
>>> Error: Can't install libgcc10 because conflicting ports are active: libgcc-devel
>>> Error: Follow to report a bug.
>>> Error: Processing of port Julia failed
>> Is there any way to install Julia?
>> Many thanks
>>  Andrew

More information about the macports-users mailing list