provide latest OS root certificates via port?

Richard L. Hamilton rlhamil at
Wed Nov 3 05:56:17 UTC 2021

I tried that too, and it didn't work for me either. Turns out from a comment on that ticket I mentioned previously that mpstats and other MacPorts commands (like "port"?) don't use /usr/bin/curl, they have a tcl binding to (by default, the system version of) libcurl. So replacing the executable doesn't help. I gather one can replace MacPorts (not the ports, but the base installation) with a version compiled from source with an option to use its own curl (or actually libcurl) rather than the system one Looks like a bit of a nuisance to do; apparently there's been long unresolved discussion about whether or not to change the default installation to do that, but while I see the upside to the change (more stuff works on older systems, and their stats  don't go unreported), I haven't seen the downside arguments.

> On Nov 3, 2021, at 00:39, raf <macports at> wrote:
> Thanks! That worked on 10.14. I couldn't find the equivalent cert.pem
> file for /usr/bin/curl on 10.6.8 (not that the same thing would have
> worked there anyway), so I did this instead:
>  cd /usr/bin
>  mv curl curl.orig
>  ln -s /opt/local/bin/curl curl
> After that, "/usr/bin/curl" worked
> but "/opt/local/libexec/mpstats submit" still fails
> with the same error.
> cheers,
> raf

eMail:				mailto:rlhamil at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list