provide latest OS root certificates via port?

Richard L. Hamilton rlhamil at
Sat Nov 6 01:11:25 UTC 2021

mpstats uses (by default the OS version of) libcurl (which you don't want to replace like that!) and not the executable, which is why what you tried didn't work (didn't work for me either when I'd tried earlier).

As things stand, one would have to get the MacPorts source (not a port!) and build it with an option to use its own version of curl / libcurl. Or so someone explained in response to a comment I'd made on a ticket about mpstats.

> On Nov 5, 2021, at 20:58, raf <macports at> wrote:
> On Fri, Nov 05, 2021 at 09:30:28AM -0500, Ryan Schmidt <ryandesign at> wrote:
>> On Oct 31, 2021, at 04:37, raf wrote:
>>> On 10.14:
>>>> /opt/local/libexec/mpstats submit
>>> Submitting data to ...
>>> Error: Peer certificate cannot be authenticated with given CA certificates
>>>     while executing
>>> "curl post "submission\[data\]=$json" $stats_url"
>> We need to make a server configuration change. See
> Thanks.
> Unfortunately, mpstats submit still doesn't work on 10.6.8,
> even with /usr/bin/curl replaced with a symlink to
> /opt/local/bin/curl. I don't understand that.
> /usr/bin/curl works there with
> the symlink in place.
> cheers,
> raf

eMail:				mailto:rlhamil at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list