geant4 and/or geant4.10.0

Михаил Коротков mikhail.g.korotkov at
Wed Sep 29 09:01:48 UTC 2021

Dear Mojka,
Could you please to explain what I have to do for using Geant4.
I have installed Geant4.10.6 by
 sudo port install geant4 
And seems everything is ok.
Then I run in the /opt/local/libexec/Geant4/geant4.10.6/
But when I tried to make .. I got the

CMake Error at CMakeLists.txt:24 (find_package):
  By not providing "FindGeant4.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Geant4", but
  CMake did not find one.

  Could not find a package configuration file provided by "Geant4" with any
  of the following names:


  Add the installation prefix of "Geant4" to CMAKE_PREFIX_PATH or set
  "Geant4_DIR" to a directory containing one of the above files.  If "Geant4"
  provides a separate development package or SDK, be sure it has been

And the second question is - can I work with the Geant4 in python?
If yes what I have to do?
It seems to me that in any case I need to add something in PATHS.

I work on Mac OS BIG SUR with M1.

Thank you very much,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list