x86_64 version of libncurses; libintl

Murray Eisenberg murrayeisenberg at gmail.com
Wed Aug 31 13:51:22 UTC 2022

> On 31 Aug2022, at 9:41 AM, Daniel J. Luke <dluke at geeklair.net> wrote:
> On Aug 31, 2022, at 9:36 AM, Murray Eisenberg <murrayeisenberg at gmail.com> wrote:
>> dyld[3024]: Library not loaded: '/opt/local/lib/libintl.8.dylib'
>>  Referenced from: '/usr/local/bin/bash'
>>  Reason: tried: '/opt/local/lib/libintl.8.dylib' (mach-o file, but is an incompatible architecture (have (arm64), need (x86_64))), '/usr/local/lib/libintl.8.dylib' (no such file), '/usr/lib/libintl.8.dylib' (no such file)
>> /usr/local/bin/sage: line 20:  3024 Abort trap: 6           /usr/bin/env - PATH="$PATH" $MIN_ENV "$SYMLINK"/venv/bin/sage "$@"
>> I find no port named libintl or intl available. But there are available ports  with “libintl” as part of their names, e.g., phpxx-intl, py-elib.intl, p5.30-libintl-perl. 
>> I haven’t a clue as to which of those to try!
> You can use `port provides` to figure out which port an installed file is from:
> % port provides /opt/local/lib/libintl.8.dylib
> /opt/local/lib/libintl.8.dylib is provided by: gettext-runtime

Ahhh … that solved the issue for me! I uninstalled gettext-runtime and in its place installed its +universal variant. 

And now the sage command works as expected.

I didn’t know about the MacPorts “provides” command.

Thank you!

Murray Eisenberg		murrayeisenberg at gmail.com
Mobile (413)-427-5334
503 King Farm Blvd #101		
Rockville, MD 20850-6667	

More information about the macports-users mailing list