port upgrade outdated hangs networking

phlebas at cantab.net phlebas at cantab.net
Sat Jan 15 16:57:17 UTC 2022

This is extraordinary .. it presumably is a bug in MacOS.

Running MacOS 10.15.7  on MacBook Pro 2016

I am updating various already installed packges in the usual way:
sudo port upgrade outdated

Everything goes along fine until the software reached gd2.
I then see:

--->  Fetching archive for gd2
--->  Attempting to fetch gd2-2.3.3_1+x11.darwin_19.x86_64.tbz2 from 
--->  Attempting to fetch gd2-2.3.3_1+x11.darwin_19.x86_64.tbz2 from 
--->  Attempting to fetch gd2-2.3.3_1+x11.darwin_19.x86_64.tbz2 from 
--->  Fetching distfiles for gd2

At this point the networking on the machine hangs.
I cannot kill the port process. I cannot reach the
offending machine even by ping; I cannot use
the network from another terminal nor browser.

Obviously, this is not a problem with Macports (is it?)
I mean, how can an attempt to retrieve a package from
some remote location actually hang my networking.

This problem is completely replicable on my machine. I reboot the machine
and everything is back to normal. Then fire up port again
.. get same messages as above.. then hangs again. I
have tried waiting for two hours before retrying --
same result. I have tried it on a different box
but that package was not needed. I will work on it
further tests.

It seems wildly improbable, but has anyone else experienced
this or anything like it? I am completely baffled.
(Except for one thing: the quality of MacOS has been in decline
now since the demise of Jobs)

Rob Stevens
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20220115/e19db343/attachment.htm>

More information about the macports-users mailing list