port upgrade outdated hangs network

phlebas at cantab.net phlebas at cantab.net
Sun Jan 16 19:28:00 UTC 2022


Thanks for your brilliantly helpful response.
Yes.. the pings are indirectly to blame!!
No, I am not running a third party firewall.
But I read the notes and noticed the comments about
changing the max_hosts_to_ping: I had noticed
after the hang that there were upwards of a dozen
hung pings.

In order I had done the following

1. After 24 hours I tried the exact same port upgrade command again... 
same result.

2. So, ok, after 15 minutes or so, I donned my debugging hat and executed:
    port -v -v -v upgrade outdated
... now it did not choke on gd2! ... several other packages are 
installed .... then it hangs on ghostscript!!

   Clearly, something extremely odd was going on here. I think it has 
nothing to
  do with turning on debug (-v -v -v) -- I think that is a red herring.
  It seems that some other condition on the network cleared,
  possibly a condition on the macports mirror, which now allowed gd2
  to download. Yes consistent with the ping stuff... variations in response
  to pings could easily give different result

So I change the max_hosts_to_ping to 10.
Eureka. It works. No hang.
It is very clear, I believe, that there is some serious bug
in MacOS networking stack which is present not only in BigSur
but also in Catalina.

I am posting this followup on the user group

On 2022-01-15 21:36, Joshua Root wrote:
> This is extraordinary .. it presumably is a bug in MacOS.
> Running MacOS 10.15.7  on MacBook Pro 2016
> I am updating various already installed packges in the usual way:
> sudo port upgrade outdated
> Everything goes along fine until the software reached gd2.
> I then see:
> --->  Fetching archive for gd2
> --->  Attempting to fetch gd2-2.3.3_1+x11.darwin_19.x86_64.tbz2 from
> https://packages.macports.org/gd2
> --->  Attempting to fetch gd2-2.3.3_1+x11.darwin_19.x86_64.tbz2 from
> https://nue.de.packages.macports.org/gd2
> --->  Attempting to fetch gd2-2.3.3_1+x11.darwin_19.x86_64.tbz2 from
> https://ema.uk.packages.macports.org/gd2
> --->  Fetching distfiles for gd2
> At this point the networking on the machine hangs.
> I cannot kill the port process. I cannot reach the
> offending machine even by ping; I cannot use
> the network from another terminal nor browser.
Are you running any third-party firewall? This looks a lot like 
<https://trac.macports.org/ticket/61683>, though that was on Big Sur. I 
would agree it's certainly an OS bug in any case.

You can try the edits mentioned in the ticket to see if it's the pings 
that are triggering the bug. A quick workaround if you just need to get 
gd2 installed is to download the distfile manually as per 

- Josh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20220116/327834dc/attachment.htm>

More information about the macports-users mailing list