port diagnose and xcode

Ryan Schmidt ryandesign at macports.org
Sun Mar 13 02:42:11 UTC 2022

On Mar 10, 2022, at 18:40, James Secan wrote:

> In working my way through my recent “phantom ports” issue I ran the command “port diagnose” and was more than a bit surprised by the output line:
> Error: currently installed version of Xcode, none, is not supported by MacPorts.
> followed by a list of the version supported under my version of macOS (El Capitan, in this case).  Where is port getting this information?  I have Xcode 8.2.0 installed, and none of my attempts to install ports have run into any trouble related to Xcode not being installed.  I ran "pkgutil -v --pkg-info=com.apple.pkg.CLTools_Executables” which shows that I have 8.2.0 installed, and the appropriate MacOSX.sdk files are in /Library/Developer/CommandLineTools/SDKs.  I also tried this on my test Catalina system, with the same result.
> Is something wrong with my ports setup?

Both com.apple.pkg.CLTools_Executables and /Library/Developer/CommandLineTools/SDKs are related to the Xcode command line tools, which are separate from Xcode. So I guess you have the Xcode command line tools installed but do not have Xcode installed. For many ports, this is fine. For those where it is not, they should tell you to install Xcode.

More information about the macports-users mailing list