Hello all,<br><br>I was on a leave of absence for a few months and when I came back I noticed that, in Software Update on our Mac at our office which has Darwin (and now Mac) Ports installed suggested that there is a new X11 update from Apple that among other things fixes fonts. I have the previous X11 User and SDK packages installed on our machines but have  instead used XFree86 via Darwin (and now MacPorts) just fine.
<br><br>Is there any reason to install Apple&#39;s update? Is it recommended by the MacPorts community? <br><br>Possibly related (though maybe not), while I was gone, someone in our office upgraded the same Mac to 10.4.8 (but they did not install the new X11 package as suggested by Software Update). I have now noticed that after launching XDarwin (
e.g. &quot;startx&quot;) successfully, if I try to next run OpenOffice 2 I am now unable to and I am seeing this error:<br><br>----------------------------<br><br>$ ./soffice<br>dyld: Library not loaded: @executable_path/libicuuc.dylib.26
<br>&nbsp;&nbsp;&nbsp; Referenced from: /Volumes/ports/Applications/OpenOffice.org2.0.app/Contents/openoffice.org2.0/program<br>&nbsp;&nbsp;&nbsp; Reason: image not found<br>soffice: line 233: 21134 Trace/BPT trap&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &quot;$sd_prog/$sd_binary&quot;&nbsp; &quot;$@&quot;
<br><br>----------------------------<br><br>I don&#39;t recall having this error before I left for my leave of absence and I&#39;m wondering if it is at all related to a 10.4.8 update and possibly requires the new Apple X11 update even though I&#39;m using XFree86?
<br><br>Thank you for any suggestions!<br><br>TM<br>