<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">
Hello,<br><span class="Apple-tab-span" style="white-space:pre">        </span>The problem thus far is not firefox-x11; but, the failure to install two of its dependencies, namely:  heimal and libcanberra.  Heimal already has a ticket (17857) to which I posted a possible patch I found on the internet.  I do not know enough about MacPorts to test the viability of the patch or to use the patch as a work around.  Libcanberra fails because a dependency has not been installed, namely: libvorbis:<div><br></div><div><div>c-76-121-207-181:~ frank$ sudo port install libcanberra</div><div>--->  Configuring libcanberra</div><div>Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_libcanberra/work/libcanberra-0.10" &amp;&amp; ./configure --prefix=/opt/local --enable-gtk " returned error 1</div><div>Command output: checking pkg-config is at least version 0.9.0... yes</div><div>checking for ALSA... no</div><div>checking soundcard.h usability... no</div><div>checking soundcard.h presence... no</div><div>checking for soundcard.h... no</div><div>checking sys/soundcard.h usability... no</div><div>checking sys/soundcard.h presence... no</div><div>checking for sys/soundcard.h... no</div><div>checking machine/soundcard.h usability... no</div><div>checking machine/soundcard.h presence... no</div><div>checking for machine/soundcard.h... no</div><div>checking for PULSE... no</div><div>checking for GST... yes</div><div>checking for GTK... yes</div><div>checking for gconftool-2... /opt/local/bin/gconftool-2</div><div>Using config source xml:merged:/opt/local/etc/gconf/gconf.xml.defaults for schema installation</div><div>Using $(sysconfdir)/gconf/schemas as install directory for schema files</div><div>checking for TDB... no</div><div>checking for lynx... yes</div><div>checking for VORBIS... configure: error: Package requirements ( vorbisfile ) were not met:</div><div><br></div><div>No package 'vorbisfile' found</div><div><br></div><div>Consider adjusting the PKG_CONFIG_PATH environment variable if you</div><div>installed software in a non-standard prefix.</div><div><br></div><div>Alternatively, you may set the environment variables VORBIS_CFLAGS</div><div>and VORBIS_LIBS to avoid the need to call pkg-config.</div><div>See the pkg-config man page for more details.</div><div><br></div><div><br></div><div>Error: Status 1 encountered during processing.</div><div><br></div><div>The work around to this problem was to:</div><div><br></div><div><span class="Apple-tab-span" style="white-space:pre">        </span> sudo port install libvorbis</div><div><br></div><div>before:</div><div><br></div><div><span class="Apple-tab-span" style="white-space:pre">        </span>sudo port install libcanberra.<br></div><div><br></div><div>I did not find a ticket to upgrade the port about the dependency omission.  Is one needed to get this fixed?</div><div> <span class="Apple-style-span" style="border-collapse: separate; border-spacing: 0px 0px; color: rgb(0, 0, 0); font-family: Helvetica; font-size: 12px; font-style: normal; font-variant: normal; font-weight: normal; letter-spacing: normal; line-height: normal; text-align: auto; -khtml-text-decorations-in-effect: none; text-indent: 0px; -apple-text-size-adjust: auto; text-transform: none; orphans: 2; white-space: normal; widows: 2; word-spacing: 0px; "><div>Frank J. R. Hanstick</div><div><a href="mailto:trog24@comcast.net">trog24@comcast.net</a></div><div><br class="khtml-block-placeholder"></div><br class="Apple-interchange-newline"></span> </div><br></div></body></html>