Portfile guidelines (was [26328] trunk/dports/gnustep/Etoile/Portfile)

Ryan Schmidt ryandesign at macports.org
Thu Jun 21 13:51:54 PDT 2007

On Jun 20, 2007, at 10:29, Yves de Champlain wrote:

> - more obscure names should either have a good description or a  
> clearer name like with_* / without_* / enable_* / disable_* to at  
> least give a clue if we are triggering a dependency or an inner  
> mechanism.  A good example : disable_utf8mac,  
> disable_extra_encodings, enable_cp932fix (libiconv).

This was suggested once, and implemented in a few ports, but I still  
don't see the advantage over the "normal" MacPorts variant naming,  
which would be, respectively, +utf8mac, +no_extra_encodings, and  

More information about the macports-dev mailing list