Portfile guidelines (was [26328] trunk/dports/gnustep/Etoile/Portfile)

Yves de Champlain yves at macports.org
Thu Jun 21 14:06:59 PDT 2007

Le 07-06-21 à 16:51, Ryan Schmidt a écrit :

> On Jun 20, 2007, at 10:29, Yves de Champlain wrote:
>> - more obscure names should either have a good description or a  
>> clearer name like with_* / without_* / enable_* / disable_* to at  
>> least give a clue if we are triggering a dependency or an inner  
>> mechanism.  A good example : disable_utf8mac,  
>> disable_extra_encodings, enable_cp932fix (libiconv).
> This was suggested once, and implemented in a few ports, but I  
> still don't see the advantage over the "normal" MacPorts variant  
> naming, which would be, respectively, +utf8mac,  
> +no_extra_encodings, and +cp932fix.

Well, if we could have a "normality" definition written in the new  
committers docs, that would just be many times better than having the  
most advantageous naming scheme anyway.


More information about the macports-dev mailing list