Slang upgrade

Ryan Schmidt ryandesign at
Sat Jun 23 07:36:49 PDT 2007

On Jun 21, 2007, at 17:06, Sbranzo wrote:

>>> /usr/bin/ld: warning prebinding disabled because of undefined  
>>> symbols
>>> /usr/bin/ld: Undefined symbols:
>>> _SLrline_init
>>> _SLrline_open2
>>> collect2: ld returned 1 exit status
>>> make[1]: *** [slsh_exe] Error 1
>>> make: *** [static] Error 2
>> _SLrline_* seem to be readline functionality. Do you have a non- 
>> MacPorts
>> readline installation in /usr/local/lib perhaps?
> No, all programs are installed through macports.
> [sbranzo] gufo ~ $ l /usr/local/
> total 0
> drwxr-xr-x 4 root wheel 136 2007-01-12 14:31 bin
> drwxr-xr-x 5 root wheel 170 2007-06-10 20:36 man
> drwxr-xr-x 3 root wheel 102 2006-12-05 17:46 share

Ok. I just tried installing the slang port (1.4.9_0) and it worked  
for me, on Intel Core 2 Duo. The slang2 port (2.1.0_0) worked, too.

This leads me to continue to suspect a rogue readline library  
somewhere on your system. First, is your MacPorts readline up to  
date? I have readline 5.2.001_0 installed.

Next, do you have any readline installed anywhere else? Did you maybe  
used to use Fink and still have /sw/lib around? Maybe you've set the  
DYLD_LIBRARY_PATH environment variable? If you can't find it, try  
installing with the debug and verbose flags, then search the output  
for "readline"; maybe that will point out where slang is finding this  
incompatible readline library.

$ sudo port -dv install slang

Is your OS up to date? Is your Xcode up to date?

More information about the macports-dev mailing list