Slang upgrade

Sbranzo sbranzo at
Sat Jun 23 07:54:49 PDT 2007

On 23/06/07 09:36, Ryan Schmidt wrote:
> Ok. I just tried installing the slang port (1.4.9_0) and it worked for me, 
> on Intel Core 2 Duo. The slang2 port (2.1.0_0) worked, too.


> This leads me to continue to suspect a rogue readline library somewhere on 
> your system. First, is your MacPorts readline up to date? I have readline 
> 5.2.001_0 installed.

$ port installed readline
The following ports are currently installed:
  readline @5.2.001_0 (active)

> Next, do you have any readline installed anywhere else? Did you maybe used 
> to use Fink and still have /sw/lib around? Maybe you've set the 
> DYLD_LIBRARY_PATH environment variable? If you can't find it, try installing 
> with the debug and verbose flags, then search the output for "readline"; 
> maybe that will point out where slang is finding this incompatible readline 
> library.

I don't have fink installed nor DYLD_LIBRARY_PATH set.

I tryed to uninstall slang2 (2.0.4_0) and reinstall slang 2.1.0_0 and it

> Is your OS up to date? Is your Xcode up to date?
Yes, Yes :-)

It was just a matter of uninstalling the previous version.

Thanks a lot for your help,

More information about the macports-dev mailing list