William Davis frstan at
Mon Apr 7 07:46:12 PDT 2008

On Apr 7, 2008, at 4:08 AM, Randall Wood wrote:

> On Mon, Apr 7, 2008 at 3:25 AM, Guido Soranzio <guido.soranzio at 
> > wrote:
>> On Apr 7, 2008, at 9:10 AM, William Davis wrote:
>>> As I previously reported: I did (and still do) have rarian  
>>> installed.
>> Have you already tried to reinstall it with
>> "sudo port -f uninstall rarian ; sudo port install rarian" ?
> I think I might understand the problem now. At some point port may
> have attempted to activate, and been blocked by the then active
> scrollkeeper port. Upgrading scrollkeeper may have deactivated
> scrollkeeper without activating rarian, leading to the empty state
> that William saw.
> Is rarian active? If "port list active | grep rarian" does not return
> "rarian   @0.8.0   textproc/rarian" then a "sudo port activate rarian"
> should do the trick.
>> -Guido
> -- 
> Randall Wood
> randall.h.wood at
> "The rules are simple: The ball is round. The game lasts 90 minutes.
> All the rest is just philosophy."

macintosh:~ frstan$ port list active | grep rarian
rarian                         @0.8.0          textproc/rarian
macintosh:~ frstan$
and I previously reported:
macintosh:~ frstan$ port installed rarian
The following ports are currently installed:
   rarian @0.8.0_0 (active)
macintosh:~ frstan$
which runs somewhat faster btw.

ok,I tried Guido's suggestion and uninstalled (-f) rarian and  
reinstalled it.
Now both bug-buddy and gnome-applets upgrade ok!

I'll go on with my upgrades of the other 5 programs I previously  
reported but so far this does seem to fix the problem.
Im sorry to have been so "persnickkidy" Randall. I know you do a LOT  
of work for the MacPorts system, and I appreciate that.
Still and all, can you imagine how frustrated I felt when after doing  
"what I was told to do" suddenly program after program would not  
upgrade AND the path back to the old system was blocked? AND nobody  
seemed to believe there was a real problem?

best regards

William Davis
Mac OS X.5.2 Darwin 9.2.2
Xquartz 2.2.0 - (xorg-server 1.3.0-apple13)
Mac Mini Intel Duo @ 1.86 GHz

Mundus vult decepi, ego non

More information about the macports-dev mailing list