[MacPorts] #14901: firefox-x11 does not provide file-selection browsers (fwd)

robert delius royar apple at frinabulax.org
Thu Apr 17 03:38:52 PDT 2008

Comments are inline in your quoted response

Wed, 16 Apr 2008 (10:29 -0400 UTC) Stefan Bruda wrote:

> Hi,
> Apologies for resurrecting this somehow old thread.
> I am using firefox-x11 all the time (I simply hate the Mac OS GUI and
> it's lack of sloppy focus so I am trying to stay under X as much as
> possible) and the lack of file browser annoys the heck out of me.
> This is a really long standing problem.  I have also inquired on this
> list awhile ago but got no response.  Other than the file browser (or
> lack thereof) the port works fine on my machine (MBP 2,2).
> At 18:37 -0400 on 2008-4-2 robert delius royar wrote:
> >
> > I recall from my own attempts to build SeaMonkey for Mac X11 that I
> > could not get it to link in the gnome-vfs components (listed as
> > required in the port file).  It always insisted on trying to link
> > in the Carbon
> Looking at the port file, the firefox-x11 port does use gnome-vfs
> apparently.  I have not watched the build process though.  Instead, I
> tried (to tweak the configuration flags) to no effect.  Have you made
> any attempt at this?  If so, with what effect?

I tried editing the configure files to change references to Mac OS 
sections and Frameworks so that Mac compilations would be treated as 
GTK/Unix, but I was unable to find exactly where the compilation would 
switch from running as an X-based compilation to a Mac Carbon 
compilation.  The current Macports port does not have the build or crash 
problems that the earlier one I tried to work out did.  For the earlier 
ports, I managed to get the Carbon frameworks not to be added, but then 
the program would crash when i tried to get a file browsing 
dialog--sometimes the first try, and other times on subsequent tries. 
It was still not linking properly.

I do still have the end-of-line Mozilla that works really well under 
X--really well in that I can leave it running for weeks.  It is outdated 
and doesn't support much of what Firefox does on my Linux system (also 
running X.org's X).

  If you run otool -L on the resulting executable (firefox-bin) and its 
Mozilla directory libraries, do you find references to 
/opt/local/lib/libgnomevfs*.dylib?  I cannot see them in mine.  Instead 
I see references to Corefoundation and Coreservices Frameworks.

I do not understand the autoconf tools really at all.  I can make minor 
changes to configure files, but the Firefox build system is so complex 
that it would require someone who understood autoconf and the system to 
make it so that OS X with X11 was recognized as a valid GTK-based UI. 
It looks as though the folks who wrote the Mac part just never assumed 
there was a Gnome package to use for OS X.

> I meant to try some more stuff in this respect (I also meant to answer
> this email earlier... ;-) ) but so far I did not quite find the time
> to do it right, I just poked around now and then (without any
> noticeable effect).
> > Ticket URL: <http://trac.macosforge.org/projects/macports/ticket/14901>
> > MacPorts </projects/macports>
> > Ports system for Mac OS
> Cheers,
> Stefan

Dr. Robert Delius Royar                   Associate Professor of English
Morehead State University                             Morehead, Kentucky

More information about the macports-dev mailing list