[MacPorts] #15274: Warning: the following items did not execute (for macfuse): org.macports.build # (cp: invalid option -- X)

Kevin Ballard eridius at macports.org
Tue May 13 22:00:08 PDT 2008

On May 13, 2008, at 7:31 PM, Charles Darwin wrote:

> On May 13, 2008, at 8:05 PM, Kevin Ballard wrote:
>> On May 13, 2008, at 6:51 PM, Charles Darwin wrote:
>>>> The easiest thing for you would simply be to uninstall coreutils 
>>>> +with_default_names, but I assume you installed that for a reason.
>>>> -Kevin Ballard
>>> That's right. And I am getting the same error when I am building  
>>> from the source.
>>> 07:49:00> sudo ./build_macfuse.sh
>> I would be very surprised if it worked, given that the problem lies  
>> in the build scripts in the fusefs.xcodeproj Xcode project file.
>> If you uninstall coreutils+with_default_names you should be able to  
>> install macfuse just fine (heck, you could simply deactivate  
>> coreutils, install macfuse, then reactivate coreutils if you want).  
>> When I push out macfuse 1.5, I'll make sure to patch it to fix this  
>> issue, and I'll inform the upstream project about it.
>> -Kevin Ballard
> This guy seems to be the trouble maker:
> ~/macfuse/core/10.5/fusefs/build/fusefs.build/Release/All.build/ 
> Script-54C6DE950B5F7755002D9FD9.sh
> Replacing `cp -pRX' with `cp -pR' doesn't help either. Some other  
> guy is feeding the X …
> I deactivated the coreutils and now macfuse is rolling… Well it just  
> finished its job; installed with no problem.

I just committed r36749 which bumps the macfuse port to 1.5 and  
includes a patch that should fix your problem. Within 12 hours the  
PortIndex should be rebuilt and you should be able to `port sync` to  
get the changes and install.

-Kevin Ballard

Kevin Ballard
eridius at macports.org

More information about the macports-dev mailing list