Problem updating git-core

Ivan Larionov xeron.oskom at
Tue Apr 1 15:58:07 PDT 2014

git-core depends on p5.16, related ticket

You should use perl5_12 variant if you want to build it with perl 5.12.

With best regards, Ivan Larionov.

On 02 апр. 2014 г., at 2:07, Thomas Lockhart <tlockhart1976 at> wrote:

> On 4/1/14 2:06 PM, Joshua Root wrote:
>> On 2014-4-2 04:01 , Thomas Lockhart wrote:
>>> On 3/31/14 11:23 PM, Ryan Schmidt wrote:
>>>> On Mar 31, 2014, at 18:06, Thomas Lockhart wrote:
>>>>> Has anyone else noticed a problem fetching the git tarball from
>>>>> I can do so successfully through my browser but it stalls
>>>>> with a zero-length .TMP file when trying to update the port. The
>>>>> update was prompted by running "selfupdate" then "upgrade outdated".
>>>>> I was hoping it was some misbehavior of but this has been
>>>>> trouble for a couple of days now. Any suggestions for debugging this?
>>>> That does sound like misbehavior of that server. Have you talked to
>>>> them about it?
>>>> MacPorts eventually gives up on servers that are delivering files too
>>>> slowly, so if you just wait, it should eventually either finish
>>>> downloading (if it’s just going slowly), or re-try from a different
>>>> server.
>>> I left it to try for more than an hour and for several shorter - but
>>> still very long - intervals. I have not seen it give up yet and suspect
>>> that whatever the failure mode is it is not getting detected by MacPorts
>>> infrastructure.
>>> I am not sure what to report to since it downloads quickly
>>> through my web browser (~30 seconds on my slow home connection and
>>> faster elsewhere). I've tried this at least a couple of times with no
>>> troubles, while the MacPorts download has failed consistently over a
>>> dozen or so tries over three days now.
>> MacPorts uses libcurl, so what happens if you try downloading the file
>> with curl? If it gets stuck, you can probably pass it some debug flags
>> to see what's going on. If not, the definitive tool for debugging the
>> download problem would be wireshark.
> curl (from MacPorts) works first time. port is still hanging, with an additional odd behavior on day 3 of this. This afternoon port decided that there were other dependencies of git-core which needed updating too:
> $ sudo port install git-core
> --->  Computing dependencies for git-core
> --->  Dependencies to be installed: p5.16-error p5.16-net-smtp-ssl p5.16-io-socket-ssl p5.16-net-libidn p5.16-net-ssleay
> where previously p5.12 was being used. I'm sure that there was no recent "port selfupdate" which might have affected this since the last time I tried. Not sure where the state is getting retained (or removed).
>> As a workaround, you can add to host_blacklist in
>> macports.conf so you can update your ports in the meantime.
> Thanks for the tip. I'll try this soon, but will poke a bit more at port first.
> Regards,
>                           - Tom
> _______________________________________________
> macports-dev mailing list
> macports-dev at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list