Yosemite build debugging? (subversion-javahlbindings)

Daniel J. Luke dluke at geeklair.net
Tue Oct 28 12:09:16 PDT 2014

(see ticket #45496 - https://trac.macports.org/ticket/45496)

I don't use the javahl-bindings, but it's been reported that they crash on Yosemite. What's interesting to me is that the test suite also crashes when run from within MacPorts, but if I do a build outside of MacPorts (as the macports user) the test suite runs fine.

Upstream suggested that different libraries were being used, but DYLD_PRINT_LIBRARIES output shows that that's not the case. I looked at dtruss output (and also tried running under trace mode to see if it made a difference), but I haven't found anything yet.

I also tried disabling the sandbox in my local copy of macports, but that didn't seem to make a difference.

Anyone see anything like this and/or have thoughts on what might be causing it?
Daniel J. Luke                                                                   
| *---------------- dluke at geeklair.net ----------------* |                          
| *-------------- http://www.geeklair.net -------------* |                          
|   Opinions expressed are mine and do not necessarily   |                          
|          reflect the opinions of my employer.          |                          

More information about the macports-dev mailing list