port select and python ...

petr 976F at ingv.it
Thu Feb 18 02:53:22 PST 2016

> On 18 Feb 2016, at 11:32, Aljaž 'g5pw' Srebrnič <g5pw at macports.org> wrote:
> On 18 febbraio 2016 at 11:01:58, petr (976f at ingv.it) wrote:
>> Hi all,
>> I realise that there quite some inconsistency in the naming of select port naming, select groups and targets names when port select is used with python.
> Inconsistencies in python port naming? Surely you must be kidding :P

Well, I’d say Python port naming itself is decent (maybe not perfect, but still okay).

>> * Some python related select ports use a `py-` prefix, most do not ….
>> py-cairosvg_select  
>> py-cssselect  
>> py-html2text_select  
>> py-pss_select  
>> py-sympy_select
>> * Same for the name of the group
>> * For the version target names patterns:
>> ${real_name}{python.version}
>> ${real_name}-{python.version}
>> py{python.version}-${real_name}
>> Is there a recommend way to name all these? Or are we free to pick anything we like? 
>> Should there be some recommendation?
> I think the saner way would be py-${real_name}_select for the select port and py${python.version}-${real_name} for the values. Ideally we would rename all the ports this way, but it’s gonna be quite complicated I fear :/

Well, what ever scheme is fine for me, but would be great if we come up with the preferred one. I am about to commit a new select and would like to have some guideline. Though, we might want base the decision on the current code base. The scheme you are proposing is rarely used. 

I think renaming would be some work but not the big problem. The issue is that there are probably migration issues for people which already have used some values which would then be renamed. I guess there is no clean migration path for users.


> --
> Aljaž Srebrnič a.k.a g5pw
> My public key:  http://bit.ly/g5pw_pubkey

More information about the macports-dev mailing list