llvm / clang / cctools / ld64 version consistency question

Ken Cunningham ken.cunningham.webuse at gmail.com
Wed Jul 27 23:31:03 PDT 2016

Thanks for taking the time to give such a detailed answer. 

I can see what I did, after reading your note and ticket -- I ran into the libLTO bug as well, but instead of seeing it as a bug, I thought I had messed up something in the tool configuration by mixing clang/ld64 versions (and I guess sorta did).

I did manage to work around it and get a functional clang-3.8 system, and a functional ld64 (and deactivated clang-3.7).

Maybe I'll leave all that alone for a while now :>

I see Jeremy is sorting all this out so others don't fall into this trap.


On 2016-07-27, at 7:26 PM, Mihai Moldovan wrote:

> On 27.07.2016 03:22 PM, Ken Cunningham wrote:
>> Having run into an unexpected problem with clang-3.7 segfaulting not long ago
>> after a 3.7 minor version update, and then an interesting libLTO incorrect
>> "version error" when I tried to upgrade the compiler chain from clang-3.7 to
>> clang-3.8, I'd like to have a slightly better understanding of how these tools
>> fit together.
> This is a bug and not intended behavior. I have created a new ticket #51929 for
> this, including a description of what is wrong.[0]

More information about the macports-dev mailing list