Weird situation after updating paho-mqtt

Mojca Miklavec mojca at
Fri Jun 10 02:42:49 PDT 2016


Some time ago (I made the commit on 2016-06-07, I don't remember when
I actually did things) I ran
    port livecheck maintainer:<me>
which listed py-paho-mqtt as updated to version 1.2

So I went ahead and upgraded the port.

Then I suddenly realized yesterday that livecheck now returns
    Error: livecheck failed for py-paho-mqtt: extracted version '1.1'
is older than livecheck.version '1.2'

The site
in fact says "latest release: 1.1"

The repository
lists version 1.2, but

There exists
lists version 1.1.

I wonder whether this livecheck error was perhaps a consequence of
or some related change around that. It's quite possible that I ran
livecheck *before* running selfupdate and getting that particular
update. In particular I remember that I changed some ports of mine
which the commit above "overwrote" before I committed (more or less
the same) changes myself.

(I wanted to add that weird enough didn't contain the file
for 1.2, but I just realized that the file suddenly appeared there.
Most likely it just needed some time before the suitable script for
syncing was executed.)

Does anyone have a clue of what exactly is going?

I'm also curious why I'm getting the error. From my past experience
sometimes livecheck would report stupid things like

    py-paho-mqtt seems to have been updated (port version: 1.2, new
version: 1.1)

This is certainly (still) the case for many perl modules (partially a
consequence of my recent switch to metacpan, but even if metacpan
contains older releases for unknown reasons, it's still weird that
older versions are reported as newer).


More information about the macports-dev mailing list