Help with a Portfile

iEFdev eric at
Tue Jan 15 06:18:20 UTC 2019

On 1/14/19 7:21 , Joshua Root wrote:
> So, fetching and patching work fine for me with your Portfile.fetch.git
> after removing the fetch.type line and setting the correct checksums.
> You should set an appropriate version though (hashes are not suitable
> because they change pseudorandomly rather than monotonically increasing
> like a version number should.)
Thanks! Well, I made this since this was the only one working for me. I'd like
to use a release instead - like the other file..

> Yes, that would be a problem. It's because Lion doesn't support TLS >
> 1.0. You can work around it by downloading the file with a browser that
> does support newer TLS versions and putting it in the location shown by
> `port distfiles`. Once the port is added to the main repo, it will be
> mirrored and users of older OS versions can download it from the mirrors.
> - Josh
That looks like a good option, but it feels a bit off when you can't confirm
yourself it's right. But, if I follow the pointer below from Ryan (no
tarball_from, or distname)…

$ port distfiles libapache2_mod_fastcgi
--->  Distfiles for libapache2_mod_fastcgi
[libapache-mod-fastcgi-upstream-2.4.7_0910052141.tar.gz] /opt/local/var/macports/distfiles/libapache2_mod_fastcgi/libapache-mod-fastcgi-upstream-2.4.7_0910052141.tar.gz
 sha256: 0
 size: 0
  ... <snip />
$ sudo wget
-O  /opt/local/var/macports/distfiles/libapache2_mod_fastcgi/libapache-mod-fastcgi-upstream-2.4.7_0910052141.tar.gz

// …and then get the cheksums and size etc.

I'll give it a try. And hope I can ask for someone to check/verify it was
correct (ie. file/numbers).

I have this one and 2 more I need to make, and then I can start migrating from
my own install to MP's. :)

On 1/15/19 1:35 , Ryan Schmidt wrote:
>> In my Portfile… Don't know if to treat the “upstream/”-part as a part of the tag, or as a prefix. I have tried both:
>> github.setup        ByteInternet libapache-mod-fastcgi 2.4.7_0910052141 upstream/
>> github.tarball_from releases
>> distname            libapache-mod-fastcgi-upstream-2.4.7_0910052141
> Do not use "github.tarball_from releases" for this project because this project does not offer any release downloads. Leave github.tarball_from and distname at their default values.
Thanks! Great point. When it doesn't work, you start adding things to hopefully
make it going. :)

> You cannot fetch from GitHub using the curl bundled with a macOS version that old.
Would it be possible to link around the problem in any way, if not just
temporarily? Just replace curl with a newer did'n't work.

When I run “port fetch” - all I see is port running tclsh5.8... no curl.

· Eric
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list