Issues with compiler flags in gfortran

Nicolas Pavillon nicos at
Mon Jan 21 14:47:28 UTC 2019


I stumbled on some issues with the fortran compiler that I cannot really understand. They might be linked with other topics discussed recently about cctools, but it still seems somewhat different. 

This happens with the port OpenBLAS, where the compilation fails when flags to compile AVX instructions yield errors during compilation, as described in the following tickets: <>

However, when I tried even more basic flags such as -march=native, compilation also fails with errors such as 
/var/folders/x8/q7j02h4d661_p7cjh42_jh380000gn/T//ccqkNy6A.s:103:no such instruction: `vxorps %xmm0, %xmm0,%xmm0'

I then tried with another gfortran compiler outside of macports, and it could compile without any issue if I remove macports’ prefix from the path, which seems to indicate that the issue is coming from the assembler in macports.

My best guess is that as in cctools is too old, but I am not sure about that. Also, if it is correct, I wonder how this could be solved. Any ideas?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list