openssl source install with trace mode bugged

Mihir Luthra 1999mihir.luthra at
Mon Jun 3 13:50:51 UTC 2019


I noticed that on a “new" MacPorts installation, if we try to install
openssl with flags   -st, it will fail.

Problematic lines in main.log with debug on are :-

:info:configure darwintrace[30583:0x10fc915c0]:
= 2

:info:configure perl: posix_spawn:
/opt/original-base/var/macports/sip-workaround/502/usr/bin/perl5.18: No
such file or directory

:info:configure Command failed:  cd
&& ./Configure --prefix=/opt/original-base -L/opt/original-base/lib no-krb5
--openssldir=/opt/original-base/etc/openssl shared zlib darwin64-x86_64-cc

:info:configure Exit code: 1

Also this won’t occur if I install perl5.28 port separately. It doesn’t
depend on that port but configuring in port perl5.28 does certain steps
that makes installing port openssl possible. So even if I terminate
installing of port perl5.28 after it is done configuring, it would be
possible to install port openssl.

I tried checking main.log with debug enabled but it crashes possibly due
default logging being in stderr and causing interference with port
install. I tried changing default logging location but doesn’t seem to work
for me.

It can be a machine specific problem. Can anyone else confirm this?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list