openssl source install with trace mode bugged

Rainer Müller raimue at
Thu Jun 6 22:23:14 UTC 2019

On 03.06.19 15:50, Mihir Luthra wrote:
> I noticed that on a “new" MacPorts installation, if we try to install
> openssl with flags   -st, it will fail.
> Problematic lines in main.log with debug on are :-
> :info:configure darwintrace[30583:0x10fc915c0]:
> posix_spawn(/opt/original-base/var/macports/sip-workaround/502/usr/bin/perl5.18)
> = 2
> :info:configure perl: posix_spawn:
> /opt/original-base/var/macports/sip-workaround/502/usr/bin/perl5.18: No
> such file or directory

Indeed, I was able to reproduce this problem on macOS 10.12 Sierra in a
completely new prefix. The file is just not there.

This file is a copy of the original file in /usr/bin in order to evade
the SIP protection that prevents DYLD_* variables in the environment.
Normally it should be copied if it does not exist or if the file in
/usr/bin is newer. Somehow this seems to have failed for some reason
that needs to be determined.

> Also this won’t occur if I install perl5.28 port separately. It doesn’t
> depend on that port but configuring in port perl5.28 does certain steps
> that makes installing port openssl possible. So even if I terminate
> installing of port perl5.28 after it is done configuring, it would be
> possible to install port openssl.

I would assume this step creates the copy of perl5.18 that was missing
before. It should not matter which port you configure as long as it uses
/usr/bin/perl5.18 in trace mode.

> I tried checking main.log with debug enabled but it crashes possibly due
> default logging being in stderr and causing interference with port
> install. I tried changing default logging location but doesn’t seem to
> work for me.

I did not understand what you tried in this paragraph.
What do you mean by "crashes"?


More information about the macports-dev mailing list