ACTION REQUIRED: Set your SMTP password

Clemens Lang cal at
Mon Nov 23 19:08:51 UTC 2020

Hi Ryan,

On Sun, Nov 22, 2020 at 09:19:43PM -0600, Ryan Schmidt wrote:
> I tried just now. (2020-11-23 03:14 UTC) It failed. The sheet
> said:
> [...]
> There is a button to open the "Connection Doctor". In the Mail
> Connection Doctor window, the MacPorts IMAP server is shown as being
> online ("Connection and login to server succeeded.") but the MacPorts
> SMTP server is shown as being offline ("Trying to log in to this SMTP
> account failed. Verify that the username and password are correct.)
> There is a checkbox to Log Connection Activity, which was unchecked. I
> checked it and tried again. The log then contained:
> > WROTE Nov 22 21:17:38.435 [kCFStreamSocketSecurityLevelTLSv1_2] -- -- port:993 -- socket:0x6040028ad080 -- thread:0x604000c6ee80
> > 
> > READ Nov 22 21:17:38.587 [kCFStreamSocketSecurityLevelTLSv1_2] -- -- port:993 -- socket:0x6040028ad080 -- thread:0x604000c6ee80
> > 14.5508 NO [SERVERBUG] Internal error occurred. Refer to server log for more information. [2020-11-23 03:17:38] (0.001 + 0.000 secs).

Port 993 is serving IMAP, and these commands are imap commands. Those
should thus not be related to SMTP.

Usually, the logfiles contain

  postfix/submission/smtpd[PID]: SESSIONID: client=HOSTNAME[IP], sasl_method=LOGIN, sasl_username=HANDLE at

for each successful login on SMTP. The last successful login for your
handle was on 2020-11-22 13:03:54 UTC. I'm guessing your network
provider did not change since then. I see a connection to our SMTP
server on 2020-11-23 03:14:24, which disconnects a second later:

  Nov 23 03:14:24 braeburn postfix/smtpd[PID]: connect from RYAN_HOSTNAME[RYAN_IP]
  Nov 23 03:14:25 braeburn postfix/smtpd[PID]: disconnect from RYAN_HOSTNAME[RYAN_IP] ehlo=2 starttls=1 quit=1 commands=4

Note the difference between postfix/smtpd and postfix/submission/smtpd.
That's the difference between port 25 and port 587 on the server. Login
and mail submission only works on port 587.

Please make sure your mail client is configured to port 587. That should
solve the problem.


More information about the macports-dev mailing list