issues with meld and python, full 99% forever

Riccardo Mottola riccardo.mottola at
Sat Apr 6 20:30:27 UTC 2024


I use meld to compare and develop, especially ArcticFox against full 
Gecko tree. I don't know if there are alternatives, but it proves to 
handle big trees and also complicated compare details. However, it is 
highly complex in its dependencies being in python, gtk3 and related.
There was a time when it worked well on 10.6, 10.7 and 10.11 up to 
10.13, the only systems I have at hand. About 1-2 years ago, don't 
remember exactly.

Then degradation happened of different nature

1) refresh of the file tree started to be bad, some items do not 
display, maybe on the left or the right side, rarely both. However, 
everything was functional and clicking on a file, even if not visible, 
got a correct compare
2) on 10.6 and 10.7 it stopped completely working, the main windows 
doesn't open anymore

Yet on 10.11 and later, except the refresh issue, it continued working. 
Nice. Then

3) comparison of files takes 99% CPU forever. I waited for hours and see 
the python process there. However retrying sometimes help with another file.
Sometimes, closing the offending file comparison yields back the CPU, 
sometimes not, hinting to some hanging. thread or so.

I use meld on Linux and it works and doesn't have this problem. I tried 
enabling/disabling syntax highlighting and it is not related.
I fear there is something that breaks python or broken in python itself.

I don't know if problem 3) and 1) can be reproduced with small 
repositories. Someone said on 10.14 there were  no issues, it needs to 
be tested again.

Are there python tests to be run ? Maybe they could help diagnose.


More information about the macports-dev mailing list