livecheck and curl 8.7.1

René J.V. Bertin rjvbertin at
Fri Apr 19 18:46:10 UTC 2024


For a few years now I've copied libcurl.4.dylib and dependencies into $prefix/libexec/lib/pextlib1.0 and then use install_name_tool magic to ensure uses this copy. This solves the problems with livechecks or even downloads failing because of unsupported SSL certificates on my older OS.

I just tried this with libcurl from curl 8.7.1 and get the error below, both on Mac and on Linux:

DEBUG: Fetching
DEBUG: Using CURL options --append-http-header {Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8} --enable-compression
Error: cannot check if openssl3 was updated (curl_multi_info_read() returned {.msg = CURLMSG_DONE, .data.result = 23 (!= CURLE_OK)}, but the error buffer is not set. curl_easy_strerror(.data.result): Failed writing received data to disk/application)

The error suggests that the output couldn't be saved but doing `system "cat $tempfile"` in the error catching code suggests that the download worked just fine.

Any idea what's happening here? I'd check the curl utility to see if it gives a similar error but using that tool correctly is higher rocket science apparently :-/


More information about the macports-dev mailing list