[MacPorts] #56398: libvpx @1.7.0: Toolchain is unable to link executables

MacPorts noreply at macports.org
Wed May 2 04:15:17 UTC 2018

#56398: libvpx @1.7.0: Toolchain is unable to link executables
  Reporter:  cgilles  |      Owner:  dbevans
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:
Resolution:           |   Keywords:
      Port:  libvpx   |

Comment (by kencu):

 the MacPorts versions of ld64 don't speak TAPI. TAPI is new, and it's an
 Apple-only thing right now. It might come out into the open and we might
 get it in the open-source world. There is talk of this on the clang-dev
 mailing list.

 For now, to make this work, you have to use Xcode's ld64, which is newer,
 and speaks TAPI. Then it works fine (just tried it). Do this:
 sudo port -v install ld64 +ld64_xcode

 and it will build with clang-3.9 and probably anything else you try. You
 can just leave the linker set like that -- it should handle anything you
 throw at it.

 For MacPorts, there is some logic in making that the default installation
 as this same error has come up a number of times already, in other ports,
 when ld64 is called in by something on macOS 10.13.

Ticket URL: <https://trac.macports.org/ticket/56398#comment:3>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list