[MacPorts] #58793: poppler @0.79.0 build failure

MacPorts noreply at macports.org
Mon Aug 5 20:48:47 UTC 2019

#58793: poppler @0.79.0 build failure
 Reporter:  weissman  |      Owner:  (none)
     Type:  defect    |     Status:  new
 Priority:  Normal    |  Milestone:
Component:  ports     |    Version:  2.5.4
 Keywords:            |       Port:  poppler
 I tried to upgrade my port of poppler, but the build failed. I cleaned it,
 uninstalled it, and tried to reinstall, but the build failed again. The
 problem seems to be that it's looking for the wrong llvm version -- from
 the attached log:

 {{{:info:build fatal error: otool: can't find or exec: /opt/local/bin
 /llvm-objdump-mp-4.0 (No such file or directory)}}}

 I have llvm version 8.0 installed instead, including {{{opt/local/bin
 /llvm-objdump-mp-8.0}}}. Any suggestions on how I should proceed?

Ticket URL: <https://trac.macports.org/ticket/58793>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list