darwinports broken on intel?

Kevin Prichard kprichard at gmail.com
Mon Dec 4 07:08:13 PST 2006

As a follow-up, I also upgraded XCode to the very latest (as of
yesterday.)  I also updated python to 2.5 with the MacPython
installer, though darwinports doesn't seem to have much in the way of
python code.

This seems to be a problem in Pextlib, or building it anyways, as the
error indicates that osx is having trouble reading that one file.
Searching around I see that others have had the same problem, but no
solutions yet that I haven't tried.  Is this perhaps a PPC-Intel
compatibility issue?  I'm at my wits end here, the only other thing I
can think to do is start reinstalling other packages, maybe even OS X,
in the hopes of discovering the cause of pextlib's untimely demise.


On 12/3/06, Kevin Prichard <kprichard at gmail.com> wrote:
> My darwin/mac/ports installation is totally b0rked - unclear what the
> triggering event was.
> It'd been a couple weeks since I last used the port command when, a
> day after receiving the very recent round of osx security updates, I
> attempted to install apache2.  This is what I saw-
> $ sudo port list
> can't find package Pextlib 1.0
>     while executing
> "package_native require Pextlib 1.0"
>     ("eval" body line 1)
>     invoked from within
> "eval package_native $args"
>     (procedure "package" line 14)
>     invoked from within
> "package require Pextlib 1.0"
>     (procedure "dportinit" line 311)
>     invoked from within
> "dportinit ui_options global_options global_variations"
> Error: /opt/local/bin/port: Failed to initialize ports system, can't
> find package Pextlib 1.0
> I believe this was version 1.3 (going by ./base/dp_version.)  So I
> tried upgrading to 1.3.2, the latest.  Following successful build, I
> got the following response to 'make test'--
> . . .
> ===> making test in src/pextlib1.0
> /usr/bin/tclsh tests/curl.tcl Pextlib.dylib
> no suitable image found.  Did find:
>         /Users/exeteremeritus/packages/dp/DarwinPorts-1.3.2/src/pextlib1.0/Pextlib.dylib:
> mach-o, but wrong architecture
>     while executing
> "load $pextlibname"
>     (procedure "main" line 2)
>     invoked from within
> "main $argv"
>     (file "tests/curl.tcl" line 54)
> make[2]: *** [test] Error 1
> make[1]: *** [test] Error 1
> make: *** [test] Error 1
> The file it "did find" appears to have been built along with all the
> others.  Here's my ./configure line:
> ./configure  --build=i686-apple-darwin8.8.1  --target=i686-apple-darwin8.8.1
> FWIW, I also tried "ppc-apple-darwin8.8.1" and
> "powerpc-apple-darwin8.8.1" - both built, both had the same problem.
> Googling around, I see others have had this problem, but no clear
> solution in hand.  Any ideas?
> Cheers,
> Kevin P

More information about the macports-users mailing list