darwinports broken on intel?

Kevin Prichard kprichard at gmail.com
Sun Dec 3 15:39:03 PST 2006

My darwin/mac/ports installation is totally b0rked - unclear what the
triggering event was.

It'd been a couple weeks since I last used the port command when, a
day after receiving the very recent round of osx security updates, I
attempted to install apache2.  This is what I saw-

$ sudo port list
can't find package Pextlib 1.0
    while executing
"package_native require Pextlib 1.0"
    ("eval" body line 1)
    invoked from within
"eval package_native $args"
    (procedure "package" line 14)
    invoked from within
"package require Pextlib 1.0"
    (procedure "dportinit" line 311)
    invoked from within
"dportinit ui_options global_options global_variations"
Error: /opt/local/bin/port: Failed to initialize ports system, can't
find package Pextlib 1.0

I believe this was version 1.3 (going by ./base/dp_version.)  So I
tried upgrading to 1.3.2, the latest.  Following successful build, I
got the following response to 'make test'--

. . .
===> making test in src/pextlib1.0
/usr/bin/tclsh tests/curl.tcl Pextlib.dylib
no suitable image found.  Did find:
mach-o, but wrong architecture
    while executing
"load $pextlibname"
    (procedure "main" line 2)
    invoked from within
"main $argv"
    (file "tests/curl.tcl" line 54)
make[2]: *** [test] Error 1
make[1]: *** [test] Error 1
make: *** [test] Error 1

The file it "did find" appears to have been built along with all the
others.  Here's my ./configure line:

./configure  --build=i686-apple-darwin8.8.1  --target=i686-apple-darwin8.8.1

FWIW, I also tried "ppc-apple-darwin8.8.1" and
"powerpc-apple-darwin8.8.1" - both built, both had the same problem.

Googling around, I see others have had this problem, but no clear
solution in hand.  Any ideas?

Kevin P

More information about the macports-users mailing list