Install issues

Ryan Schmidt ryandesign at
Tue Dec 5 11:26:54 PST 2006

On Dec 5, 2006, at 11:32, Marshall Rodriquez wrote:

> I tried looking through the mailing list archives and didn't see my  
> big issue covered. Basically I've installed version 1.320 and get  
> the following error when I try to run the selfupdate:
> Marshall-Rodriquezs-Computer:/opt/local/bin marshallrodriquez$  
> sudo ./port selfupdate
> DarwinPorts base version 1.320 installed
> Error: ./port: selfupdate failed: couldn't open "/opt/local/var/db/ 
> dports/sources/ _dpupdate1/base/config/ 
> dp_version": no such file or directory
> I checked and the folder is there, though there is a space in it  
> which seems to be the disconnect. Is that supposed to be there?

Where is there a space? The path "/opt/local/var/db/dports/sources/ 
rsync.rsync.macports.org_dpupdate1/base/config/dp_version" should  
exist without any spaces in it. (My email program will probably  
insert some into this message, but there shouldn't be any.)

> I also checked the .profile file and the recommended paths are in  
> there, but I still have to navigate to the /opt/local/bin directory  
> to even run the command. I should also mention that I have to use  
> the ./ to run the command, which makes me wonder if something is  
> set up wrong since the documentations says it should work without  
> it. I have tried setting up the older versions of DarwinPorts  
> before I tracked down where the current source was, if that might  
> give any indication. If someone has had this issue or know where I  
> could read up on it, any help will be appreciated. Thank you

I don't know about .profile; I use the file ~/.bash_profile and it  
works fine. I include a line like this:

export PATH=/opt/local/bin:/opt/local/sbin:/opt/local/lib/mysql5/bin: 

More information about the macports-users mailing list