Install issues

Marshall Rodriquez marshall_rodriquez at
Wed Dec 6 09:26:30 PST 2006

On Dec 5, 2006, at 2:48 PM, Ryan Schmidt wrote:

> On Dec 5, 2006, at 15:26, Marshall Rodriquez wrote:
>> On Dec 5, 2006, at 11:26 AM, Ryan Schmidt wrote:
>>> On Dec 5, 2006, at 11:32, Marshall Rodriquez wrote:
>>>> I tried looking through the mailing list archives and didn't see  
>>>> my big issue covered. Basically I've installed version 1.320 and  
>>>> get the following error when I try to run the selfupdate:
>>>> Marshall-Rodriquezs-Computer:/opt/local/bin marshallrodriquez$  
>>>> sudo ./port selfupdate
>>>> DarwinPorts base version 1.320 installed
>>>> Error: ./port: selfupdate failed: couldn't open "/opt/local/var/ 
>>>> db/dports/sources/ _dpupdate1/base/ 
>>>> config/dp_version": no such file or directory
>>>> I checked and the folder is there, though there is a space in it  
>>>> which seems to be the disconnect. Is that supposed to be there?
>>> Where is there a space? The path "/opt/local/var/db/dports/ 
>>> sources/rsync.rsync.macports.org_dpupdate1/base/config/ 
>>> dp_version" should exist without any spaces in it. (My email  
>>> program will probably insert some into this message, but there  
>>> shouldn't be any.)
>> The space is " _dpupdate1". It's in the error message  
>> and in the folder name, so it seems like it's deliberate, but it  
>> doesn't allow things to work. I'll try looking through the source  
>> and see if it's there somewhere.
> Have you manually edited the file /opt/local/etc/ports/ports.conf  
> to reference If so, check if there is a space  
> after "" in the relevant line; if so, remove it.

Ok, last night I went through and removed every file and folder I  
could find and then reinstalled, and tried the .bash_profile to add  
the path. Now DP is installed and runs, though when I go to install  
fox or glut it seems to be trying to get them from .  
Naturally, it just runs through those 4 servers over and over again.  
One odd thing is it's trying to fetch the file XFree86-4.5.0- 
src-3.tgz or XFree86-4.5.0-src-4.tgz , and tries to fetch it for  
either of my attempted installs. When I look in my sources.conf file,  
I see things pointed at rsync:// 
dports . Am I correct that this(where the port is looking for the  
file) is something set server side?

Marshall Rodriquez

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list