A variety of problems

Daniel J. Luke dluke at geeklair.net
Mon Dec 11 15:43:05 PST 2006

On Dec 11, 2006, at 5:21 PM, Eric Angell wrote:
>> This seems odd, but I'm not sure from your description exactly what
>> happened.
> Sorry, I didn't save the logs from everything because I didn't
> expect to have such a hard time, so I don't have exact error
> messages.  I'll try the explanation again.  As far as I could
> see, the only error message that I got during the qt3 build
> process was from `mv ~destroot/opt/local/lib/*.*
> ~destroot/opt/local/lib/qt3/lib`, which told me '.../*.*: No such
> file or directory'.

Um, so you have a user named destroot and have somehow managed to get  
macports to use it's home directory as the destroot when building ports?

(or are you just using ~ as a shortcut for the normal path to the  

> (When I first got the error, I touched foo.bar in the
> appropriate directory, but the installed qt package then didn't
> include any libraries, so aqbanking failed to configure.  I left
> that part out of the original description, sorry).

Yep, the qt3 port must have been broken (or at least broken on your  

>>> *: if I run port with -f, I expect the step to run, regardless of
>>> what the state file says; I don't expect to have to edit the
>>> state file by hand.
>> You shouldn't have to, but you don't say what you ran (and what
>> happened), why you decided to modify the state file, and what
>> happened after you did.
> Once I had tricked qt3 into finishing by touching foo.bar, it
> created a .tgz and deleted the entire work directory.  Since that
> didn't fix my problem, I wanted to futz with it some more, so I
> ran `port uninstall qt3`, which appropriately removed all of the
> installed files.  I don't remember the exact order I ran other
> commands in, but I think I tried a `port install qt3`, figuring it
> would fail in the same way, but it just found its tgz package and
> reinstalled it, so I uninstalled again, then ran `port clean
> --archive qt3`, which deleted the .tgz.

I think here you actually wanted port clean --all qt3 (as that would  
have removed the archive and the now stale work directory).

FYI, archives are off by default on new macports installs.

> It removed the .tgz, but it did not modify the state file, and a
> further `port -f archive qt3` refused to create the archive,
> insisting that it already existed.

That's a bug that should probably be fixed. port -f archive should  
force new archive creation if it doesn't.

Could you file a bug on this? [I might even feel motivated to fix  
it ;-) ]

> Okay, I may be naive in assuming that `port upgrade all` might
> help with my build problems.  Again, I don't remember the
> original build error from qt3, but I'm pretty sure it changed
> after I did the upgrade all.

That's possible. It's possible that some out-of-date other macports  
provided software could have caused the original failure.

> Given that you think my current install is damaged based on the
> `port provides` behavior, I could see this as a potentially
> reasonable step.  I know of at least one program (NmapFE) which
> is installed in /Applications/Darwinports/ rather than
> /opt/local.  Is it likely that there is anything else outside
> /opt/local?

There are a couple of ports that install under /Applications/ 
Darwinports or /Applications/MacPorts

macports provided X11 also doesn't install under /opt/local (because  
it refuses to work correctly if installed there).

If you forget to remove anything, you'll just find out later when you  
go to install that same package again (as macports will refuse to  
install over it unless you use force). So you'll be able to clean it up.

> I also note that the portfile for NmapFE no longer
> exists, but I haven't checked yet to see if that's because it's
> more of a Cocoa app anyway.

IIRC It's because NmapFE isn't supported anymore and is superseded by  
the +gtk2 nmap variant.

> If I assume that the only thing reinstalling from scratch would
> cost me is a bit of compile time, then it makes sense just to do
> it.  Since it could botch the currently working installation of
> one of my ~60 packages, I'm a bit wary.

You could always tar up /opt/local before you remove it and restore  
it if your new install doesn't work ...
Daniel J. Luke
| *---------------- dluke at geeklair.net ----------------* |
| *-------------- http://www.geeklair.net -------------* |
|   Opinions expressed are mine and do not necessarily   |
|          reflect the opinions of my employer.          |

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : http://lists.macosforge.org/pipermail/macports-users/attachments/20061211/a2323c3f/PGP.bin

More information about the macports-users mailing list