sudo port selfupdate (was Re:

Jean-Christophe Helary fusion at
Wed Dec 13 22:30:57 PST 2006

>>> After I install the package, I do "sudo port selfupdate" but get  
>>> the following message:
>>>> $ port install Pextlib
>>>> can't find package Pextlib 1.0
>>>>     while executing
> <snip>
>>>> Error: /opt/local/bin/port: Failed to initialize ports system,  
>>>> can't find package Pextlib 1.0
>>> Anything I missed on the way ?
>> I have seen several people report that. I do not understand it.  
>> There is this bug report:
>> Does anything in that ticket help you?
> I'm currently downloading XCode 2.4.1 (close to 1gb...)
> I'll report when I'm done.

I've installed XCode 2.4.1, reboot, re-downloaded MacPorts 1.3.1 for  
OSX 10.4, installed seemingly successfully but a "sudo port  
selfupdate" still produces the same error.

Besides, I've tried the "./configure" command for the tar package and  
I still get a "tcl has been compiled with the nothread option" error  
message that aborts the configuration.

So I am left with no way whatsoever to run macports...


More information about the macports-users mailing list