sudo port selfupdate (was Re:

Paul Guyot pguyot at
Wed Dec 13 22:42:34 PST 2006

Le 14 déc. 06 à 15:30, Jean-Christophe Helary a écrit :

> I've installed XCode 2.4.1, reboot, re-downloaded MacPorts 1.3.1  
> for OSX 10.4, installed seemingly successfully but a "sudo port  
> selfupdate" still produces the same error.
> Besides, I've tried the "./configure" command for the tar package  
> and I still get a "tcl has been compiled with the nothread option"  
> error message that aborts the configuration.
> So I am left with no way whatsoever to run macports...

Could you please do:
* which tclsh
* tclsh
  $ array get tcl_platform
* /usr/bin/tclsh
  $ array get tcl_platform

and report the result here.


I'm guessing that configure is picking another tclsh that doesn't  
have threaded support built-in. On a 10.4.8 MacMini with all software  
updates and Xcode but nothing else, the built-in tclsh has threaded  
support built-in.

Besides, I think your default tclsh cannot load Pextlib, either  
because it doesn't like Pextlib (seems to be the problem that was  
solved by upgrading Xcode on Intel machines) or because it doesn't  
load libraries the way MacOS X's default tcl loads them.


More information about the macports-users mailing list