sudo port selfupdate (was Re:

Chuck Ferril cferril at
Wed Dec 13 23:13:33 PST 2006


I ran into this same problem and was finally able to fix it...

The pkgIndex.tcl file in /opt/local/share/darwinports/pextlib1.0 (as  
well as in darwintrace1.0) is missing the following line:

            package ifneeded Pextlib 1.0 [list load [file join $dir  

The Pextlib.dylib file is also not universal. I opened the  
DarwinPorts-1.3.1.pkg, extracted the Archive.pax.gz file, extracted  
the contents and copied the proper dylib file from there...

I tried many other things trying to fix the problem, but I believe  
this was the actual cure for the problem.


On Dec 14, 2006, at 12:30 AM, Jean-Christophe Helary wrote:

>>>> After I install the package, I do "sudo port selfupdate" but get  
>>>> the following message:
>>>>> $ port install Pextlib
>>>>> can't find package Pextlib 1.0
>>>>>     while executing
>> <snip>
>>>>> Error: /opt/local/bin/port: Failed to initialize ports system,  
>>>>> can't find package Pextlib 1.0
>>>> Anything I missed on the way ?
>>> I have seen several people report that. I do not understand it.  
>>> There is this bug report:
>>> Does anything in that ticket help you?
>> I'm currently downloading XCode 2.4.1 (close to 1gb...)
>> I'll report when I'm done.
> I've installed XCode 2.4.1, reboot, re-downloaded MacPorts 1.3.1  
> for OSX 10.4, installed seemingly successfully but a "sudo port  
> selfupdate" still produces the same error.
> Besides, I've tried the "./configure" command for the tar package  
> and I still get a "tcl has been compiled with the nothread option"  
> error message that aborts the configuration.
> So I am left with no way whatsoever to run macports...
> JC
> _______________________________________________
> macports-users mailing list
> macports-users at

More information about the macports-users mailing list