issues with the gnucash port

barparlo at barparlo at
Tue Sep 19 21:36:39 PDT 2006

first, many thanks to whomever put gnucash into the ports tree.

i thought that the someone would be interested in the problems that i  
ran into while installing gnucash. the first, i found a workaround  
for somewhere on the web (my apologies for the formatting):

--->  Fetching scrollkeeper
--->  Attempting to fetch scrollkeeper-0.3.14.tar.bz2
--->  Verifying checksum(s) for scrollkeeper
--->  Extracting scrollkeeper
--->  Configuring scrollkeeper
--->  Building scrollkeeper with target all
--->  Staging scrollkeeper into destroot
--->  Packaging tgz archive for scrollkeeper 0.3.14_1
--->  Installing scrollkeeper 0.3.14_1
--->  Activating scrollkeeper 0.3.14_1
Error: Target returned: Image
error: /opt/local/var/log/scrollkeeper.log already
exists and does not belong to a registered port.
Unable to activate port scrollkeeper.

i solved the issue by deleting /opt/local/var/log/scrollkeeper.log.  
it seemed innocous enough. the second problem i got was:

--->  Fetching gnucash-docs
--->  Attempting to fetch gnucash-docs-2.0.0.tar.gz
--->  Verifying checksum(s) for gnucash-docs
--->  Extracting gnucash-docs
--->  Configuring gnucash-docs
Error: Target returned: configure
failure: shell command "cd
&& ./configure --prefix=/opt/local" returned error 1
Command output: checking for scrollkeeper-config... no
configure: error: Couldn't find scrollkeeper-config.
Please install the scrollkeeper package:

i solved the problem by activating scrollkeeper. apparently, deleting  
the log file allowed port to continue but it did not attempt to  
reactivate the port.

now i have one final problem to solve. gnucash compiled successfully  
but i can't run it. i've installed apple's x server (1.1) and i get  
the following error when i invoke gnucash from the terminal:

_X11TransSocketINETConnect() can't get address for localhost:0:6000:  
No address associated with nodename
(gnucash:8820): Gtk-WARNING **: cannot open display:

i've searched the web and it suggests that the problem is associated  
with my DISPLAY environment variable. i've tried setting DISPLAY to : 
0.0 and localhost:0.0 in my .bashrc to no avail. any idea what i  
should do to correct this?

thanks in advance.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list