Ryan Schmidt ryandesign at macports.org
Wed Feb 7 15:25:09 PST 2007

On Feb 7, 2007, at 06:32, Dimitri Hendriks wrote:

>>> dyld: Library not loaded: /opt/local/lib/libintl.3.dylib
>>>   Referenced from: /opt/local/bin/gawk
>>>   Reason: image not found

>> See http://svn.macosforge.org/projects/macports/wiki/ 
>> ProblemHotlist#a2.Aportfailedtobuildupgradeorrunwithamessagereferring 
>> tolbintl.3.dylib (A port failed to build, upgrade, or run with a  
>> message referring to lbintl.3.dylib)

> Thanks for the reference. Unfortunately it does not fix my problem.
> When I run:
>   depsearch.sh libintl
> no ports are listed, from which, given the explanation,
> I infer that none of my ports depend on gettext,
> and so there are none to fix.
> Futher, I uninstalled all inactive ports with:
>   sudo port -duf uninstall
> However, upon:
>   sudo port install swi-prolog
> I get the same error message as before.

gawk depends on gettext. That's clear from the error message: /opt/ 
local/bin/gawk is trying to load /opt/local/lib/libintl.3.dylib (the  
gettext 0.14.x library) and can't find it (because gettext 0.15 and  
0.16.x install libintl.8.dylib, not libintl.3.dylib). Reinstall gawk,  
as Daniel said, so that it links against the new libintl.8.dylib  

A possible reason that depsearch.sh didn't show this to you is that  
between 2005-08-29 and 2006-05-30, gawk made use of gettext, but did  
not declare this dependency. If you installed gawk during that time,  
and haven't synced your port tree since then, your port tree doesn't  
know that gawk depends on gettext, although it does. I believe a  
"sudo port sync" should bring your tree up to date and fix that.

More information about the macports-users mailing list