[Familiar] Git Not Getting

Altoine Barker ndiscreet at gmail.com
Fri Feb 16 22:39:17 PST 2007

Hash: SHA1

I build and ran the git- from source, but that produced the same
error as I had previously posted. I used the new stable git-1.5.0 and it
worked with this command test:

git clone http://git.kernel.org/pub/scm/git/git.git test-git-clone

But still when I ran this command:

git clone http://familiar.handhelds.org/git/familiar-build.git

It failed. I would think that it is a curl type error message if it
wasn't for the fact that it worked with one http port based git
repository. Here is the exact error:

got c0a02c4137d8b7c4975ae603c0120dd1a6f3df11
walk c0a02c4137d8b7c4975ae603c0120dd1a6f3df11
got a4199a1c0bee918424aec5216eb2540cf1ca0008
got 01dada37607f23f60118475f17d1201023733e37
walk 01dada37607f23f60118475f17d1201023733e37
got cd27f64e64783e0fc871cc64a65badb178f00c29
got 1c31342b9fe16fd0ef8420905a39a0a16ba0d478
got e0fd39a56e2c4d6c7bfcaea1a0098b9babeab534
got 48747b05409ddd791c0323e0bdc8430cd6a3b6f8
got c750ad605b32777239163b0236dea55f73cf1d80
walk 48747b05409ddd791c0323e0bdc8430cd6a3b6f8
got 4129e4c523922afe3b10323fad256cfb1ac09e0e
got cf0aac99d9b73ec039fd19c5446dda20d89fa897
got f4b65ff8348e2a2760f290ba9cf75307e2e71da6
got 90ec22bee124705a9164f46a994cad1890bd92b5
got 511fae4a2562bdaa73ceff46a29b68e8e8abc8fb
got 652ebcee6e424b3bfda2519f0cc193c7536cf6db
got 890710a55428f23ba55f34a06f177c95b1225949
got cb1b64317b1fa70d3b0171ecb7f9e7bedc9dad69
got 48d417be5f6ae83ac35a816b543072ce76b54040
got fe33e5613a38d917c37c85ed94e4712feac11850
got 5dc3f4723b5fec43e04d95ccd6f862fc0975331a
got b2a838d53670a2d4f300fd2e7c5a69d42ae0c5c6
got fb950dc69feb8afa93493747f33d6e1c02659b55
got adb14a75532aeba460c62443b71db624e97a03a0
got dd06d15954ac0d7b7ec729856b1690d73a23efd6
got 103be97f189ad275cd519357bdcace99d6e643d6
got 7684a0a6e79f0b68b0944d9bb917136a41e3885f
got 590c1ef0648a438acb98730698fd129a5c707e53
got d5fdab45f0d4a814b9e4e12adebd691a3ede1f59
got f48c983ab0686d1ea717db55573081e31637f896
got 8df8e5ac5cb92ceda9d2838c21ab6f76a0ce8428
got 16bcddc4d023ec403d00de4d8eaaea7bfa6ac4d4
got c9aeefb9466529eb812abe6172df4ee02a3946f9
got df6caa28ed60273cb01f761d6eba6d44399ef2bb
got fd216a32613df6435dac9c0731885ffea5f1f238
got 25e5156619cc9f8e27c077d614d35bba1faffb56
got 64d32945ba6e8eb798948f4b9dae987864ada88c
/opt/local/bin/git-clone: line 300:  2038 Segmentation fault
git-http-fetch -v -a -w "$tname" "$name" "$1/"

That is the entire output.

My setup:
Mac OS X 10.4.8 (G4)
git 1.5.0
curl 7.16.0

- -Altoine

Altoine Barker wrote:
> That is correct, Rene. I am attempting the monumental task of porting a
> build for Mac OS X. I think it is worth the effort and long overdue.
> Well, I do not know if you saw my post after this one showing that I am
> able to use git accessing the git port, 9418, but you are correct in
> that I am unable to access the http port, 80, for git. I am recompiling
> vanilla git as we speak. I have been preparing myself for this task with
> doing many personal projects with linuxfromscratch.org. I feel that by
> tooling around with that site, has helped give me a deeper understanding
> of the linux OS and how it works in general. Thank you for your reply.
> -Altoine
> Rene Wagner wrote:
>> On Thu, 2007-02-15 at 11:00 -0800, Erik Hovland wrote:
>>> On Thu, Feb 15, 2007 at 12:24:07PM -0600, Altoine Barker wrote:
>>>> Hash: SHA1
>>>> I installed git version using macports version 1.320. My
>>>> notebook is an Apple iBook G4 running Mac OS X version 10.4.8. The exact
>>>> package of git in macports is called git-core. I use this command:
>>>> <snip>
>>>> git clone http://familiar.handhelds.org/git/familiar-build.git
>>>> </snip>
>> This is most likely a problem with a broken or incompatible curl (the
>> http library used by git) rather than with git itself.
>> But either way, OS X isn't supported as a build host and will be quite
>> a bit of work to make it work.
>>> I noticed you did not give a destination directory. Have you tried
>>> adding that?
>> That's optional. For URIs ending in "foo.git" git will pick "foo"
>> as the destination.
>> Regards,
>> Rene
Version: GnuPG v1.4.5 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the macports-users mailing list