macports-users Digest, Vol 6, Issue 48

M. White mwhite15 at
Tue Feb 27 18:28:29 PST 2007

Hi Rob,

   You can sometimes run into screwy things when you try to update a  
package installed from another source.  For instance, I installed  
octave 2.1.73 as a binary from hpc.sourceforge last year with no  
problems (it did not work completely, but it was okay).  This was  
installed in /usr/local.  I then installed octave 2.9.9 from  
hpc.sourceforge and had problems with the functionality.  Then I  
tried to use the darwin ports of octave.  This did cause me  
problems.  I had to remove the octave-2.9.9 directories from /usr/ 
local and had to rename /usr/local/include/readline.  The port of  
octave-2.9.9 would find readline.h directory under /usr/local/include/ 
readline and therefore not create its own readline directory under / 
opt/local/include.  The problem was that the header had changed.  I  
found this out in old posts install errors dealing with "readline".   
Apparently, when the port is run, it will sometimes go looking for  
things in your path, and if it finds it anywhere, it can cause  
problems if it is not fully updated. While I have not tried  
installing anything from fink, it is possible that something similar  
is happening.  You can always use "-vdt" on your ports to get more  
error reporting.

Try the commands:
    ls -l /opt/local/bin
    which emacs
and if you absolutely have to:
    locate emacs

one of these might point to why you seem to have problems with the  

However, you should be aware that even if you install this again, I  
think you may only get a command line editor.  When I ran configure,  
with the flags, it said it was checking for X, which it did not find,  
and then checked for /usr/X386 (Xfree86), which it also did not find  
(since X is under /usr/X11R6, as I recall).  So, it said that it  
configured emacs but without any windowing capability in the  
configure report (which you get with the above flags).  I also found  
the following online from: 
"emacs 662
  variants {darwin_8 darwin_7} description {The GNU Emacs text editor  
(command line only)}"

There are actually a couple of emacs ports.  Try:
    port list  | grep -i emacs
and you will find 5 of them (emacs-app, emacs, emacs-devel, xemacs  
and emacs-w3m).  You can then do:
    port variants emacs-devel
    port info emacs-devel
this one has a carbon and x11 variants.  emacs-app, is Coca based on  
Mac OS-X.  One of these might actually be the one you want.

Hopefully one of these will work.

   - M.

On Feb 27, 2007, at 1:03 PM, macports-users- 
request at wrote:

> Date: Tue, 27 Feb 2007 07:34:40 -0700
> From: Rob MacLeod <macleod at>
> Subject: Re: emacs install breaking
> To: Elias Pipping <pipping at>
> Cc: macports-users at
> Message-ID: <CED922F8-4F33-4A2D-BE6A-CFDEBCE97408 at>
> Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
> Hi
> On Feb 26, 2007, at 10:44 PM, Elias Pipping wrote:
>> sudo port -f activate emacs should solve the problem.
> Thanks for the reply.
> Unfortunately, this suggestion did not work:
> 	[idsl210:/opt/local]$ sudo port -f activate emacs
> 	Password:
> 	--->  Activating emacs
> 	Error: port activate failed: File exists
> And when I try to run the program
>   	/opt/local/bin/emacs: No such file or directory
> So I cannot seem to either completely remove the program or
> completely install it.  Each time it gets to the activate stage, I
> get the report that the file exists.
> Thanks for any suggestions!
> Cheers,
> Rob
>> Regards,
>> Elias Pipping
>> On Feb 27, 2007, at 6:29 AM, Rob MacLeod wrote:
>>> Hi,
>>> I am trying to get emacs working from MacPorts and my first try
>>> would not launch its own X-window but ran in the xterm where I
>>> launched it.  It also reported a warning that the directory
>>> 	/opt/local/share/emacs/21.4/leim
>>> was missing, which it was when I went looking.  I am not sure what
>>> this directory does or whether its absence explains why emacs was
>>> lamed.
>>> I am now trying to do a fresh install of emacs but running into
>>> problems.  I keep getting this error during installation:
>>> --->  Activating emacs 21.4a_1+darwin_8
>>> Error: Target returned: File exists
>>> Error: Status 1 encountered during processing.
>>> I have tried uninstalling emacs using
>>> 	sudo port uninstall emacs
>>> and then
>>> 	sudo port clean --all emacs
>>> and still I get this same error.
>>> Does anyone have any guesses about what might be going wrong.
>>> As background, I have used fink since the beginning of OSX time,
>>> used emacs on Unix for many more years before that.  I am trying
>>> to move from Fink to Macports but so far, the experience is
>>> mixed.  I left Fink because it was falling behind on new
>>> versions.  I hope MacPorts will work for me...
>>> Thanks,
>>> Rob

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list