question about upgrading port (getting errors)

Evan Burrows eburrows at
Sat Jun 2 06:49:09 PDT 2007


I am sure this has been asked before but I couldn't find an answer on
google.  I currently had a php5 port that had the mysql4 variant installed.
I want to add support for mysql5 instead so i tried upgrading with little
luck.  I installed mysql5 fine and then deactivated mysql4 with no problem.
When I try to then install a new version of php5 using port install php5
+apache2 +mysql5 +pear I end up getting errors after waiting a very long
time for things to compile.  The typical error is:

Error: Activating pcre 7.1_1 failed: Image error: Another version of this
port (pcre @4.5_0) is already active.
Error: Deactivating expat 1.95.7_0 failed: Image error: expat @1.95.7_0 not
installed as an image.

but in place of expat when i tried to install the php5 directly it gave an
error about pcre.  I then tried to upgrade all my updated ports using port
upgrade outdated and some were successful while others got similar errors as
described above?  What is causing this problem and how do I go about fixing
it because of of right now my LAMP install is busted and I can't get
anything accomplished until i resolve the php5 issue.  Any information would
be greatly appreciated and if I missed providing any important information
please ask and I will gladly supply it.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list