question about upgrading port (getting errors)

Jyrki Wahlstedt jwa at
Sat Jun 2 10:25:53 PDT 2007

On 2.6.2007, at 20.06, Evan Burrows wrote:

> I did try to uninstall php5 first but it gave me the following  
> error and
> didn't look as though it understood the uninstall command:
> sudo /opt/local/bin/port uninstall php5
> Password:
> Error: port uninstall failed: invalid command name
> "portuninstall::uninstall"
> So, addressing you comments..
>>> I am sorry, if I am wrong, but I understand that you tried to  
>>> install
>>> php5 +mysql5 &c while having php5 +mysql4 installed?
> I used the clean argument like you mentioned for php5, pcre, and  
> expat. And
> as I said above i tried an uninstall and it failed.. so i  
> deactivated php5
> and tried to install a new version of php5
>>> It is also hard to understand, where does pcre @4.5_0 come from.
> I have no idea what pcre has to do with a php5 install but when i  
> tried
> running the php5 install command that was one of the items that  
> threw the "
> Image error: Another version of this port (pcre @4.5_0) is already  
> active."
> error.  For that reason I mentioned that in my original email but  
> like I
> said I don't know what the relationship between that and php5 (if  
> there is
> one).
You can see the dependencies doing 'port deps': e.g. 'port deps php5'  
gives '       libxml2
         freetype') basically, variants add to these. If you say  
'port installed pcre', you see all installed versions of pcre.

> I am running 10.4.9, MacPorts 1.442, Xcode 2.4.1.  I really  
> appreciate your
> help since I am relatively new to macports and am a little  
> frustrated at
> this point.
> Thanks for the prompt response!
> Evan
Hi again,
I am a bit at loss, because I don't see any such errors, as:
jwa at lan3:midgard> sudo port -f uninstall php5 @5.2.1_3+apache2 
--->  Unable to uninstall php5 5.2.1_3+apache2+darwin_8+macosx+mysql5 
+pear+postgresql, the following ports depend on it:
--->    midgard-php4
Warning: Uninstall forced.  Proceeding despite dependencies.
--->  Uninstalling php5 5.2.1_3+apache2+darwin_8+macosx+mysql5+pear 
jwa at lan3:midgard>

(that was inactive anyway).
Have you performed sync or selfupdate lately? You could try cleaning  
out the whole port system, installing it again from scratch and doing  
selfupdate, and install php5 with variants after that. This is a bit  
of work, but ports do not behave like that in my system, I am on MBP,  
OS X 10.4.9, Xcode 2.4.1, MP 1.442
! Jyrki Wahlstedt
!	skype:jyrkiwahlstedt
! Our life is no dream; but it ought to become one and perhaps will.
! PGP key ID: 0x139CC386 fingerprint: F355 B46F 026C B8C1 89C0  A780  
6366 EFD9 139C C386

More information about the macports-users mailing list