question about upgrading port (getting errors)

Evan Burrows eburrows at
Sat Jun 2 10:06:45 PDT 2007

I did try to uninstall php5 first but it gave me the following error and
didn't look as though it understood the uninstall command:

sudo /opt/local/bin/port uninstall php5
Error: port uninstall failed: invalid command name

So, addressing you comments..
>>I am sorry, if I am wrong, but I understand that you tried to install
>>php5 +mysql5 &c while having php5 +mysql4 installed?

I used the clean argument like you mentioned for php5, pcre, and expat. And
as I said above i tried an uninstall and it failed.. so i deactivated php5
and tried to install a new version of php5

>>It is also hard to understand, where does pcre @4.5_0 come from.

I have no idea what pcre has to do with a php5 install but when i tried
running the php5 install command that was one of the items that threw the "
Image error: Another version of this port (pcre @4.5_0) is already active."
error.  For that reason I mentioned that in my original email but like I
said I don't know what the relationship between that and php5 (if there is

I am running 10.4.9, MacPorts 1.442, Xcode 2.4.1.  I really appreciate your
help since I am relatively new to macports and am a little frustrated at
this point.

Thanks for the prompt response!

On 6/2/07, Jyrki Wahlstedt <jwa at> wrote:
> On 2.6.2007, at 16.49, Evan Burrows wrote:
> > Sorry,
> >
> > I am sure this has been asked before but I couldn't find an answer on
> > google.  I currently had a php5 port that had the mysql4 variant
> > installed.
> > I want to add support for mysql5 instead so i tried upgrading with
> > little
> > luck.  I installed mysql5 fine and then deactivated mysql4 with no
> > problem.
> > When I try to then install a new version of php5 using port install
> > php5
> > +apache2 +mysql5 +pear I end up getting errors after waiting a very
> > long
> > time for things to compile.  The typical error is:
> >
> > Error: Activating pcre 7.1_1 failed: Image error: Another version
> > of this
> > port (pcre @4.5_0) is already active.
> > or
> > Error: Deactivating expat 1.95.7_0 failed: Image error: expat
> > @1.95.7_0 not
> > installed as an image.
> >
> > but in place of expat when i tried to install the php5 directly it
> > gave an
> > error about pcre.  I then tried to upgrade all my updated ports
> > using port
> > upgrade outdated and some were successful while others got similar
> > errors as
> > described above?  What is causing this problem and how do I go
> > about fixing
> > it because of of right now my LAMP install is busted and I can't get
> > anything accomplished until i resolve the php5 issue.  Any
> > information would
> > be greatly appreciated and if I missed providing any important
> > information
> > please ask and I will gladly supply it.
> >
> > Thanks,
> > Evan
> Hi,
> I am sorry, if I am wrong, but I understand that you tried to install
> php5 +mysql5 &c while having php5 +mysql4 installed? If you change
> variants, you ought to uninstall first, sorry for that. It is also
> hard to understand, where does pcre @4.5_0 come from.
> You could:
> - look at what you have installed with 'port installed' (or e.g. port
> installed name:php)
> - port clean --all expat (, and pcre and php5)
> - uninstall expat, pcre, and php5 (use -f if necessary)
> - install them again
> What version of port do you have? What operating system are you
> working on? What Xcode version do you have?
> !
> ! Jyrki Wahlstedt
> !       skype:jyrkiwahlstedt
> !
> !
> ! Our life is no dream; but it ought to become one and perhaps will.
> ! PGP key ID: 0x139CC386 fingerprint: F355 B46F 026C B8C1 89C0  A780
> 6366 EFD9 139C C386
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the macports-users mailing list