question about upgrading port (getting errors)

Ryan Schmidt ryandesign at
Mon Jun 4 13:18:51 PDT 2007

On Jun 4, 2007, at 09:57, Evan Burrows wrote:

> Yeah I tried that the other day with no luck.  Then I figured it  
> out.  It seems as though the fact that it was retaining my previous  
> install information when I originally installed darwinports was  
> what was causing the issue.  After installing the new version of  
> macports and doing a selfupdate left me with the same problem. It  
> was late at night by the time I did that so I just wiped my  
> macports install and all its references and did a fresh install and  
> then just ran a quick shell script to install everything I wanted  
> over night.  The next day when I checked everything I created the  
> startup items for the services I wanted and rebooted and I have a  
> fully functional macports install again.  Still a little weird why  
> the uninstall never worked but it is working now so that is all  
> that matters.

What do you mean, created the startup items? MacPorts should be  
creating all the necessary startup items (or, rather, LaunchDaemon  
plists, on Mac OS X 10.4). For which ports did you have to manually  
create them?

More information about the macports-users mailing list