gcc42 fails to build

Boey Maun Suang boeyms at macports.org
Wed Jun 6 05:46:08 PDT 2007

Hi Christoph,

> You can see in the logs that configure decided to use the ´ar´  
> installed by
> the binutils port. (The link in /opt/local/bin is named ´gar´ to avoid
> conflicts with Appöe's ar, but the link in
> /opt/local/i386-apple-darwin8.9.1/bin/ is named ´ar´.) Could this  
> be the
> cause? Do you have the binutils port installed?

Further to my last email on this, I installed binutils and got  
exactly the error you described, then deactivated binutils, cleaned  
gcc42 and tried installing gcc42 again, and it worked fine.  See if  
you can do a clean install of gcc42 after deactivating binutils.  If  
that works, it would be great if you could file a ticket about the  
problem (if you do, don't forget to put yourself and the maintainers  
of binutils and gcc42 into the Cc: field on the ticket, as the  
MacPorts Trac installation doesn't currently forward automatically to  
the reporter or assignee).

Kind regards,

Maun Suang

Boey Maun Suang (Boey is my surname)
Email: boeyms at macports dot org

More information about the macports-users mailing list