gcc42 fails to build

Christoph Ludwig ludwig at fh-worms.de
Thu Jun 7 10:54:57 PDT 2007

Hi Maun Suang,

On Wed, Jun 06, 2007 at 10:46:08PM +1000, Boey Maun Suang wrote:
> >You can see in the logs that configure decided to use the ´ar´  
> >installed by
> >the binutils port. (The link in /opt/local/bin is named ´gar´ to avoid
> >conflicts with Appöe's ar, but the link in
> >/opt/local/i386-apple-darwin8.9.1/bin/ is named ´ar´.) Could this  
> >be the
> >cause? Do you have the binutils port installed?
> Further to my last email on this, I installed binutils and got  
> exactly the error you described, then deactivated binutils, cleaned  
> gcc42 and tried installing gcc42 again, and it worked fine.  See if  
> you can do a clean install of gcc42 after deactivating binutils.  

I deactivated binutils and, yes, gcc42 built just fine.

> If  
> that works, it would be great if you could file a ticket about the  
> problem (if you do, don't forget to put yourself and the maintainers  
> of binutils and gcc42 into the Cc: field on the ticket, as the  
> MacPorts Trac installation doesn't currently forward automatically to  
> the reporter or assignee).

I already have an open ticket; I will add this information and also add the
CCs. (It would be nice if onthe form there were an indication along the Cc:
field like "put the maintainer and yourself in here". Of course, it would be
even better if track did that automatically, but let's stick to humble
wishes. :-) )


FH Worms - University of Applied Sciences
Fachbereich Informatik / Telekommunikation
Erenburgerstr. 19, 67549 Worms, Germany

More information about the macports-users mailing list